Free Articles, Free Web Content, Reprint Articles
Wednesday, February 26, 2020
 
Free Articles, Free Web Content, Reprint ArticlesRegisterAll CategoriesTop AuthorsSubmit Article (Article Submission)ContactSubscribe Free Articles, Free Web Content, Reprint Articles
 

Cisco CCNP 642-901 BSCI Exam Tutorial: EIGRP Adjacencies And Secondary Addresses

In contrast to what some CCNP documentation states, you can form an EIGRP adjacency with secondary addresses - but you have to be careful!  Learn the details from Chris Bryant, CCIE #12933.

I've read some non-Cisco documentation that EIGRP will not allow adjacencies to form when secondary addresses are used.  This is incorrect, but there is one common error that can result if both addresses are not secondary.  To fully prepare for the 642-901 BSCI exam, you should know about this error.  Let's take a look at R2 and R3, which will be using secondary addresses to form an EIGRP adjacency across an ethernet segment.

R2(config)#interface ethernet0

R2(config-if)#ip address 172.12.23.2 255.255.255.0

R2(config-if)#ip address 23.23.23.2 255.255.255.0 secondary

R2(config)#router eigrp 100

R2(config-router)#no auto-summary

R2(config-router)#network 23.23.23.0 0.0.0.255

R3(config)#interface ethernet0

R3(config-if)#ip address 172.12.23.3 255.255.255.0

R3(config-if)#ip address 23.23.23.3 255.255.255.0 secondary

R3(config)#router eigrp 100

R3(config-router)#no auto-summary

R3(config-router)#network 23.23.23.0 0.0.0.255

Here's the partial output of show ip eigrp neighbor on R3:

R3#show ip eigrp neighbor

IP-EIGRP neighbors for process 100

H   Address                 Interface

0   172.12.23.2             Et0

The adjacency has formed!  Note the address is actually the primary IP address on the interface, even though we used the secondary network number in the EIGRP network command.  Personally, I stay away from secondary network numbers if at all possible, but you should know that secondary IP addresses can be used to create EIGRP adjacencies.

What's the common error with using secondary addresses, you asked?  It's when an address from the same subnet is the primary interface address on one neighbor and the secondary interface address on another. Let's say we had configured R2 and R3 as follows:

R2(config)#int e0

R2(config-if)#ip address 23.23.23.2 255.255.255.0

R3(config)#interface ethernet0

R3(config-if)#ip address 172.12.23.3 255.255.255.0

R3(config-if)#ip address 23.23.23.3 255.255.255.0 secondary

On R2, we get this message:

01:54:05: IP-EIGRP: Neighbor 172.12.23.3 not on common subnet for Ethernet0 (23.23.23.2 255.255.255.0)

Since we configured 23.23.23.2 as a primary interface address on R2, the EIGRP process is looking at the primary interface address on potential neighbors.  R3's primary ethernet0 address is 172.12.23.2Health Fitness Articles, so you get the "not on common subnet" error message - and what you don't get is an adjacency! That's something to be aware of on your 642-901 BSCI exam as well as when working with EIGRP in production networks.

Article Tags: 642-901 Bsci Exam, Primary Interface Address, 642-901 Bsci, Bsci Exam, Eigrp Adjacencies, Secondary Addresses, R2(config-if)#ip Address, 2323232 2552552550, 2552552550 Secondary, R3(config-if)#ip Address, Primary Interface, Interface Address

Source: Free Articles from ArticlesFactory.com

ABOUT THE AUTHOR


Chris Bryant, CCIE #12933, is the owner of The Bryant Advantage, home of over 200 free certification exam tutorials, including CCNA certification training articles. His exclusive CCNA study guide is also available!Visit his blog and sign up for Cisco Certification Central, a daily newsletter packed with CCNA, Network+, Security+, A+, and CCNP certification exam practice questions! A free 7-part course, “How To Pass The CCNA”, is also available, and you can attend an in-person or online Cisco CCNA training boot camp with The Bryant Advantage!



Health
Business
Finance
Travel
Technology
Home Repair
Computers
Marketing
Autos
Family
Entertainment
Education
Law
Communication
Other
Sports
ECommerce
Home Business
Self Help
Internet
Partners


Page loaded in 0.049 seconds